Canon selphy cp 1300


#1

Bonjour à toute la communauté et merci d’avance pour l’aide que vous pourrez m’apporter.
Je précise que je suis ce qu’on pourrais appeler un noob mais j’essaye de me débrouiller en fouillant sur le net.
Voilà mon soucis, je suis sur un projet de photomaton pour les 30 ans de ma femme en mars. Tout fonctionne correctement sauf cette satané imprimante. J’ai acheté une canon selphy cp1300, elle est détectée dans cups mais je ne la trouve pas dans la liste. J’ai tenté de mettre les drivers pour la selphy 910 et 900 mais impossible d’imprimer. Quand je lance une page test elle me dit impossible de lire les données. La même chose quand je veux imprimer une photo directement depuis le photomaton. Je pense à un problème de pilotes mais j’avoue ne pas savoir où trouver le bon. Merci d’avoir pris le temps de me lire


#2

Salut,

Beau boulot (bon, tu feras les finitions, n’est-ce pas ? :wink: )

Page support :

Malheureusement, votre appareil n’est plus pris en charge sous le système d’exploitation sélectionné
(idem pour Linux 32 ou 64)

Fais des recherches avec “Canon selphy cp 1300” + les mots clef “Ubuntu” et “Debian” sur divers moteurs de recherches pour voir …

La mienne fonctionne avec un Rpi, mais c’est une imprimante laser un peu ancienne avec pilotes Linux.

++
.


#3

Merci pour ta réponse.
Oui les finitions seront faites, c’est une caisse que j’ai récupérer au taf d’où son état mais au moins elle ne m’a rien coûté.
J’ai vu sur la page canon que Linux n’est pas supporté mais j’ai réussi à trouvé des pilotes pour la cp1200. Ils ne fonctionnent pas pour la 1300 mais je continue mes recherches. Ça serais dommage de pas réussir, je l’ai acheté exprès :yum:


#4

Des pilotes “proches” fonctionnent parfois.
Je suis sous Linux depuis 15 ans et parfois, j’ai dû m’adapter.
Mais, en général, je fais l’inverse : l’imprimante n’est achetée que si pilotes Linux dispo :wink:


#5

Du coup je poste ici ce que j’ai trouvé. J’ai réussi à trouver le fichier ppd pour la canon selphy 1300 ici : https://www.voss.earth/2018/08/31/kurztipp-canon-selphy-wlan-drucker-cp910-oder-cp1300-unter-linux-cups-verwenden/ j’ai cherché jusque sur des sites allemands.
Le mec explique que c’est un truc qu’il a bidouillé depuis un driver de Mac. Le soucis c’est que ça ne fonctionne que en WiFi pas en USB. Vu que c’est pour une soirée dans une salle communale, ça ne m’arrange pas. Je testerais si ça marche avec un portable configuré en point d’ accès WiFi et je reviendrais poster le résultat. Il y a juste à chercher le fichier depuis cups et ça fonctionne en WiFi. A suivre.


#6

Je reviens pour dire que tout fonctionne en mettant un portable en mode point d’accès Wi-Fi et en connectant le rasp et la selphy cp1300 dessus. Mais il faut bien choisir dans cups le fichier ppd que j’ai donné sur le poste au dessus.
Je suis soulagé, le photomaton sera présent à la soirée. Reste plus qu’à trouver des perruques pour se prendre en photo et beaucoup d’alcool et ça sera le top.


#7

Bonjour,

Je tiens simplement à te remercier pour ton dernier message car je rencontre exactement le même problème que toi !

Je vais donc essayé ce soit avec un portable en mode point d’accès. Un vieux portable fonctionne, nous sommes bien d’accord ?

Tu parlais d’une bidouille depuis un driver Mac. Celle-ci est nécessaire au bon fonctionnement via point d’accès ?

Merci à toi ! :slight_smile:
Jérémy


#8

Oui il faut quand même installer le driver sur le Raspberry sinon il ne verra pas l’imprimante. Content que ça serve😉


Problème impression Photomaton Selphy CP 1300
#9

Hello,

La bonne nouvelle c’est que ça a marché, la mauvaise c’est que je ne sais pas pourquoi ni comment !!

J’ai essayé en WIFI en point d’accès, ça n’a pas fonctionné. Quand j’ai branché l’USB, une photo est sortie… Je dois encore creuser


#10

D’ailleurs, sur quel site as-tu trouvé le code du photomaton ?

Pour ma part j’utilise celui-ci : https://www.hackster.io/sabat54i/wedding-photo-booth-with-raspberry-pi-1cea3a

Le problème c’est que l’imagine finale qui est divisée en quatre (3 photo + un template du nom de l’event) est imprimé en mode Portrait sur la largeur de la photo ! En gros c’est mal cadré et je n’ai pas réussi à modifié cela…

Pas de problèmes de ton côté avec l’imprimante ?

Merci