[DEBUTANT] Connexion SSH impossible [Résolu]


#21

Salut,
Les box actuelles ont tendance à avoir un effet mémoire logique et attribuent la même IP à la même machine dans la mesure du possible me semble-t-il.
Perso, je laisse ma FreeBox en mode routeur DHCP, mais je fixe les IP de mes appareils via adresse IP fixe liée à l’adresse MAC du périphérique.

Au pire, on peut tenter adresse IP fixe liée à l’adresse MAC et on relance la procédure d’installation complète de Raspbian.
Au démarrage, si tu es en filaire, tu auras l’IP qui s’affiche et tu pourras ensuite activer le wifi.

++


#22

Salut Nabla,
On va attendre que Allparadise fasse encore des tests.
J’ai un test à lui proposer:

  1. tout arrêter
  2. lancer la box
  3. lancer le rpi
  4. vérifier son adresse ip attribuée (devrait être 1.10)
  5. tester des pings dans les 2 sens, public et privé
    *** peut-on pinger depuis une livebox ? ***
  6. lancer le pc
  7. le connecter au wifi de la box
  8. vérifier son adresse ip attribuée (devrait être 1.21 !!!)
  9. tester des pings dans les 2 sens, entre pc,box,rpi, public et privé

autre test: brancher le rpi en ethernet (cable rj45 entre la box et le rpi)

autre action: faire une mise à jour du firmware de la box (peut-être commencer par cela …)

Le tout en disablant firewall et antivirus


#23

Salut,
Yep, on lui fait faire ça et on revoit.

Et, perso, je suis partisan du RJ45, mais c’est un autre débat :slight_smile:


#24

Salut , non je n’ai pas reboot la box entre chaque modification. Mais même en ayant réinstallé différente version de debian, la box redonne à chaque fois la même adresse.

Bonjour Nabla,
Si j’essaie l’Ip fixe suis-je obligé de passer par une connexion câble paire torsadée? Ou bien puis tout faire en Wifi ?

Dans tout les cas je vais tenter ce que je peux encore avec vos indications.

Pour info le nombre de mes messages est limité car je suis nouvel utilisateur du forum. Mais je lis vos conseil et je vais tenter tout ça dans la journée si j’arrive à trouver le temps.


#25

Salut,

L’IP fixe est liée à une adresse MAC (Media Access Control) soit une “adresse ethernet” unique selon un matériel.
Tu as une adresse MAC pour ton module RJ45 et une autre pour ta carte wifi.
Tu peux avoir un adressage fixe pour ton adresse MAC liée à ton module WIFI.
Tu tapes ifconfig et l’adresse MAC de ton wifi est un truc du genre :

wlan0: blablabla
**ether b9:25:fe:65:24:32**  
blablabla

(évidemment, “blablabla” c’est pour dire qu’il y a d’autres infos :slight_smile: et l’adresse MAC est fausse car inventée par moi)

++


#26

Bonjour,
alors voila ce que j’ai fait :

1- déconnecter tout mes appareils du résau wifi
2- remonter une image toute neuve sur ma raspi
3- connecter la raspi en “RJ45” à la box
4- désactivé l’ipv6 sur raspi afin de pouvoir avoir une Ip lisible, ce qui donne : 192.168.1.22
5- ping google.com OK - ping box (192.168.1.1) OK
6- Activation wifi du Pc ==> ping sur raspi OK + ping raspi vers Pc = OK
7- Activation SSH sur raspi + reboot
8- Connexion via PuTTY OK :slight_smile:
9- Connexion de la Raspi au wifi + déconnexion “Rj45” + reboot
10- Ping raspi vers box = Ok , raspi vers google.com = OK, raspi vers Pc = NON , Pc vers box = OK , Pc vers raspi = NON

Finalement mon problème reste le même puisque j’ai impérativement besoin d’être sur le réseau wifi pour la raspi :confused:

Il semblerais donc que ce soit la box qui filtre d’une manière ou d’une autre non ?

Note : quand je repasse en wifi sur raspi, l’Ip est à nouveau 192.168.1.21


#27

Désolé, j’étais sourd,muet et aveugle depuis hier midi: panne de fibre optique dans le quartier.

Donc avec rj45 cela marche, avec le wifi cela ne marche pas.
Pourrais-tu rebooter ta box afin de partir sur des bases saines ?
Idéalement mettre à jour le firmware de la box.


#28

Bonjour,
Alors j’ai d’abord tenté de multiple paramètres sur le panneau d’administration box en vain.
Puis j’ai vérifié la mise à jour de la Box c’était déjà OK
Et j’ai simplement réinitialisé la box …
Et là “miracle” (lol), Tout fonctionne.

Mon problème est donc résolu.

Merci de m’avoir orienté et conseillé !


#29

Tant mieux !
Peut-être qu’un arp -a nous aurait fait gagner du temps !