HiFi Berry Ampli son


#1

Bonjour,

J’ai ce matériel :
https://www.kubii.fr/audio/2020-amplificateur-hifiberry-amp2-kubii-3272496008809.html

Il est noté « Vous n’avez besoin que d’une seule alimentation 12-24V pour alimenter le Raspberry Pi et l’Amp + »
Cependant, lorsque je branche mon transfo sur la carte Hifiberry, Le raspberry Pi de s’allume pas = la diode rouge reste éteinte (rien ne s’allume).

De plus, si j’alimente le Rpi par son alimentation = il s’allume mais je n’ai pas de son à sortir.

Avez-vous réussi à alimenter le Rpi directement par le biais du HifiBerry ?

Merci,


#2

Hello,

Question con :slight_smile:
–> Tu as activé le bus I2C ?

Sinon, mes lectures pour toi me donnent (entre autres) ceci :

“le branchement d’une alimentation électrique au Raspberry Pi et à l’Amp2 peut endommager la carte ! Vous ne devriez JAMAIS faire cela. Vous n’obtiendrez pas non plus de sortie sonore avec l’alimentation connectée au Raspberry Pi. Habituellement, ce genre de problèmes provient d’un câblage incorrect.”

“GPIO4 est utilisé pour contrôler la fonction MUTE de l’étage de puissance. Si vous la tirez vers le bas, la sortie est mise en sourdine.”

(Textes traduits avec www.DeepL.com/Translator)

++


#3

heu à mon avis : non vu que je sais pas ce que s’est ? il faut aller dans le BIOS (si on l’appelle comme ca) ? j’ai laissé le réglage par défaut

sinon concernant les tests de puissance voici les résultats
J’ai mis le multi-mètre sur 200 Volt et c’est parti !

Voici les résultats

9,1 V sur le GPIO de l’ampli HiFi Berry Amp 2 1.0 (broches power et ground aux extrêmitées, en diagonal comme disait Cédric)

et 37 Volts juste sur le connecteur d’entrée (de l’ampli) de forme ronde sur lequel je branche mon alim PC dont l’Output de l’ampli du PC est donnée pour du 12 V et 4A.


#4

Ca devrait ressembler à ca :

https://www.hifiberry.com/blog/introducing-the-amp2-more-power-higher-sample-rates-more-affordable/

==> négociation ? AH ?
but the effective output voltage can be higher as there is some kind of voltage negotiation between the laptop and the power adapter


#5

Yo,

Pour activer le bus I2C, ça se passe dans le raspi-config en ligne de commande ou via le mode graphique “Framboise” puis “Préférence” puis “Configuration …”


#6

Super ca fonctionne en effet et du coup j’ai activé tous les services de ce menu Configuration.

Ensuite je me dis tranquillou appliquons le mode op ci-dessous à base de dt overlay

Comme évidemment toujours pas de son sur mon haut parleur alors je lance un fichier son avec mon ami VLC que j’avais au préalablement installé sur la PI naturellement car pas fourni par défaut.

Ensuite ? Lorsque je force le fichier à être joué en double cliquant dessus et bien VLC me dit :slight_smile:périphérique AUDIO default ne peut être activé !

Après avoir fait les manip du mode op vidéo, je lance un raspi config je vais dans le menu audio et là en effet je ne vois que 3 menus : default, jack ou HDMI.

A noter que le son sort bien en HDMI …perdu que je veux activer le son de mon Haut parleur branché sur ma carte HIFI Berry Amp 2.0

Merci d’avance pour votre aide !!


#7

Merci Nabla, on y est presque je le sens !


#8

Yo,

Perso, je laisserais “defaut”.
Je n’aime pas VLC sous Raspberry ; trop lourd.
J’utilise mplayer pour les sons ou omxplayer pour les vidéos.

Si le module est pour balancer du son en cas d’alerte lors de détection d’intrusion en videosurveillance avec MotionEye, mplayer est suffisant.
sudo apt-get update && sudo apt-get install mplayer

A suivre,

Edit :
Je viens de regarder la vidéo.
Bon, moi et l’Anglais comment dire …
Mais, le truc qui me saute aux yeux, c’est qu’il parle de RetroPie et pas de Raspbian.

Sinon, en vrac (ça cause i2s et i2c), je fais autre chose et dois partir :


http://nagashur.com/wiki/doku.php?id=raspberry_pi:i2c_setup

++


#9

Super Nabla,

oui c’était bien ca !! Maintenant j’arrive à alimenter la RaspberryPi via la carte Ampli HiFI Berry Amp 2.0…autre blème le son ne sort pas sur mes hauts parleurs qui sont raccordés sur mon ampli HifiBerry et pourtant j’arrive à faire jouer un fichier mp3 et le son sort bien sur la télé via la prise HDMI.

Voici toutes les modifications de config et actions diverses :slight_smile:

voici mon fichier config.txt

hdmi_drive=0

dtparam=audio=on

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.

#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

dtoverlay=hifiberry-amp

dtdebug=1

#dtparam=i2c_arm=on

#dtparam=i2s=on

#dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

start_x=1

gpu_mem=128

enable_uart=1

dtoverlay=w1-gpio

Sur Raspi Config dans le menu Advanced/son : auto

Pour cédric, j’ai suivi ton mode op alors voici les résultats (après avoir rajouté le fichier asound.conf comme expliqué dans le mode op) :

pi@raspberrypi:/boot $ aplay -l

aplay: device_list:270: aucune carte son n’a été trouvée…

pi@raspberrypi:/boot $


#10

Yo,

Cool ; on progresse !

On teste :
sudo nano /boot/config/txt

Dans Enable audio (loads snd_bcm2835)
A la place de
dtparam=audio=on
Tu as mis
dtoverlay=w1-gpio
essayons
dtoverlay=hifiberry-dacplus

++


#11

moi je dit que ca va marcher


#12

ET ben non la carte son n’est toujours pas trouvée.

On est bien d’accord qu’il fallait mettre en commentaire la ligne : dtoverlay=w1-gpio ?


#13

Re,

Et avec dtoverlay=hifiberry-dacplus et un rebbot ; c’est pas “plus mieux” ?


#14

et non c’est toujours KO


#15

le carte son n’est toujourzs pas reconnue

$ sudo aplay -l
aplay: device_list:270: aucune carte son n’a été trouvée…
$


#16

damn, incrooyable !

idem avec une fresh install ?


#17

Sorry ? Il faut que je réinstalle raspbian ?


#18

ben, je me demande (ca m’est deja arrivé)
a force de toucher divers réglages etc, des fois on mets en vrac un systeme sans s’en rendre compte
du coup,
une fresh install (oui une reinstallation fraiche) et directement les dernieres modifs pour voir ce qu’il se passe ?


#19

je préfère éviter.

Lorsque j’ai fait des essais sur le paramètre audio-on cela réagissait bien en temps réel, je ne pense pas qu’il y ait un pb d’applicabilité des modifs du fichier Config par l’OS.


#20

@Raspix
@Glou
@rantanplan

On pourrait partir sur l’idée de passer le Rpi en démarrage possible sur USB pour tester une image toute neuve et toute fraiche de la dernière version de Raspbian sur Clef USB.
Comme ça tu gardes ton install’ mais tu peux faire des tests sur la clef.
(j’ai toujours une clef de Raspbian qui ne sert qu’aux tests).

On pourrait tester de faire une MàJ totale de cette nouvelle image + activation de i2C (via Raspi-Config)
puis “Reboot”
puis sudo apt update puis sudo apt upgrade -y puis sudo apt-get install -y python-smbus i2c-tools

Puis “Reboot” de principe.

Là, tu retires ton alim du Rpi, connectes ton HifiBerry puis son alim et …
On dit que ça démarre.

sudo i2cdetect -y 1 pour voir si ça nous dit un truc.

Ensuite :
sudo nano /boot/config/txt

Dans Enable audio (loads snd_bcm2835)
A la place de
dtparam=audio=on
Tu mets
dtoverlay=hifiberry-dacplus

Tu valides les modifications puis un petit “Reboot”

Au démarrage, tu vas sur le net lire une vidéo de “Shaka Ponk” ou de “M” (ou de ce que tu veux ; je ne serais pas là) pour voir si le son sort.
Si ça sort par ton HDMI, tu cliques sur les HP en haut à droite pour voir si tu peux passer en analogique.
Là, “Reboot”
Et tu restestes cette même vidéo.

Je précise que je n’y connais rien et que je n’ai pas de HifiBerry ; je propose de l’aide à l’aveugle avec mes maigres compétences et lectures.

@Glou et @rantanplan ; Vous validez mes propositions ?

++