Installer Brave Browser


#1

Bonjour,

J’aimerai Brave Browser sur ma RP3B+. Cependant, je n’y arrive pas. Je ne trouve aucun Tuto sur le net.
Comment faire ? Merci.


#2

Bonjour,

https://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux

C’est
sudo apt install brave-keyring brave-browser

Mais, à priori, pas prévu pour Debian ni Raspbian.
Ils ne parlent pas d’architecture ARM.

ça semble donc compromis en l’état.

Voir pour récupérer et compiler les sources ?

@+


#3

Bonsoir,

Malheureusement, ça ne fonctionne pas. Merci quand même ! Je continue à creuser le sujet …


#4

Salut,

Comme je le disais :

Une piste serait de :

@+


#5

#6

Bonjour,
Merci pour le lien mais ça ne fonctionne pas.
J’obtiens des erreurs :

Citation return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);
^

Error: ENOENT: no such file or directory, open '/home/pi/brave-browser/src/chrome/VERSION'
at Object.fs.openSync (fs.js:646:18)
at Object.fs.readFileSync (fs.js:551:33)
at checkVersionsMatch (/home/pi/brave-browser/lib/build.js:78:26)
at Command.build (/home/pi/brave-browser/lib/build.js:93:3)
at Command.listener (/home/pi/brave-browser/node_modules/commander/index.js:315:8)
at emitTwo (events.js:126:13)
at Command.emit (events.js:214:7)
at Command.parseArgs (/home/pi/brave-browser/node_modules/commander/index.js:651:12)
at Command.parse (/home/pi/brave-browser/node_modules/commander/index.js:474:21)
at Object.<anonymous> (/home/pi/brave-browser/scripts/commands.js:137:4)

npm ERR! brave@0.67.3 build: node ./scripts/commands.js build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the brave@0.67.3 build script.
npm ERR! This is most likely a problem with the brave package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./scripts/commands.js build
npm ERR! You can get their info via:
npm ERR! npm owner ls brave
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 4.14.98-v7+
npm ERR! command “/usr/bin/node” “/usr/bin/npm” “run” “build”
npm ERR! cwd /home/pi/brave-browser
npm ERR! node -v v8.11.1
npm ERR! npm -v 1.4.21
npm ERR! code ELIFECYCLE
npm WARN This failure might be due to the use of legacy binary “node”
npm WARN For further explanations, please read
/usr/share/doc/nodejs/README.Debian

npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/pi/brave-browser/npm-debug.log
npm ERR! not ok code 0


#7

Bonjour,

A quelle étape ?
As-tu comme demandé installé les prérequis ?

A+


#8

Bonjour,
Oui, j’ai installé les prérequis comme demandé.
Après “npm run init” j’obtiens l’erreur citée plus haut.


#9

Bonjour,

Là, ça dépasse mes compétences. Parfois tenter de tout reprendre à zéro avec un OS propre permet d’aller au bout d’une installation, éventuellement avec une autre carte SD pour ne pas casser la conf actuelle.

Bonne recherches
A+


#10

Bonjour,
C’est ce que je vais faire. En tout cas, merci d’avoir tenter de m’aider, ça me sera très utile par la suite.