Probleme installation mysql


#1

bonjour, je suis débutant et j’essaye d’héberger un site wordpress sur mon raspberry pi 2B en suivant ce tutoriel : https://raspbian-france.fr/installer-wordpress-raspberry-pi-nginx/
j’ai réussis a configurer Nginx mais lorsque j’essaye d’installer mysql, ça affiche :
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package mysql-server is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
mariadb-server-10.0

E: Package ‘mysql-server’ has no installation candidate

j’ai fais plusieurs recherches et je n’arrive pas a installer mysql.
es ce que vous auriez une solution?


#2

Bonjour,

Suivre le conseil “However the following packages replace it: mariadb-server-10.0”
Depuis strectch, mysql-server n’est plus dans les paquets, il est remplacé par mariadb-server qui est un fork et compatible avec mysql.

A+


#3

Salut, comment ça se fait que mysql-server soit remplacé par mariadb-server ?

Mini Militia App Lock 7Zip


#4

Salut,

Peut-être qu’il est possible de télécharger et compiler les fichiers source ?

@+


#5

Bonjour,

MariaDB est un fork de Mysql. Ils sont très proches l’un de l’autre. D’ailleurs les fichiers de conf et le process de MariaDB s’appellent mysql.
Les 2 ont été développés par le même développeur, My est le prénom de sa première fille, et Maria est le prénom de sa seconde. Le moteur Mysql à été vendu à Sun Microsystem qui devait être racheté par Oracle, et donc risquait de ne plus être libre. Par contre la licence de MariaDB apporte surtout l’assurance de rester libre.

Pour un peu plus d’infos : https://fr.wikipedia.org/wiki/MariaDB

A+


#6

Merci @jelopo, pour les infos,

Maintenant, on parle d’un nouveau mariage OpenSource, entre un couple puissant pour le développement des sites Web.

MariaDB et PHP ont un protocole sécurité (je ne connais pas les détails), solide et bien sur, Il faut que le super-utilisateur administre son site, ou ses infrastructures réseaux avec sérieux. :sunglasses:

@+