Problème port I2C résolu


#1

Bonjour, j’essaie de me connecter à une carte DAC en i2c (MCP 4725).
Donc j’ai suivi un tuto pour pour activer le port i2c.
sudo apt-get install python-smbus
sudo apt-get install i2c-tools
sudo raspi-config (puis activation du port i2c)
sudo reboot
sudo i2cdetect -y 1
Et voilà ce que j’obtiens:
pi@raspberrypi:~ $ sudo i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f
10: 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f
20: 20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f
30: 30 31 32 33 34 35 36 37 38 39 3a 3b 3c 3d 3e 3f
40: 40 41 42 43 44 45 46 47 48 49 4a 4b 4c 4d 4e 4f
50: 50 51 52 53 54 55 56 57 58 59 5a 5b 5c 5d 5e 5f
60: 60 61 62 63 64 65 66 67 68 69 6a 6b 6c 6d 6e 6f
70: 70 71 72 73 74 75 76 77
pi@raspberrypi:~ $
c’est comme si il y avait un capteur sur toutes les adresses.
Merci de me guider ou ce trouve le problème.


#2

Salut,
T’aurais pas inverser SDA et SCL ?


#3

Salut,
non je n’ai pas inversé le SDA et le SCL, j’ai vérifié à plusieurs reprises.
j’ai fait le “sudo i2cdetect -y 1” sans rien de branché sur les GPIO sda et scl:
ça me donne la même chose.


#4

Bonjour,

Tenter de désactiver et réarctiver le protocole I2C dans Raspi-config.

5 Interfacing Options
P5 I2C Enable/Disable automatic loading

A+


#5

Salut,
J’ai désactivé et réactivé toujours la même chose.


toutes les adresses sont actives, a n’y rien comprendre.


#6

Bonjour,
J’ai trouvé un topic qui présente le même soucis sur le forum anglophone, il y aura eput être d’autres pistes …

https://www.raspberrypi.org/forums/viewtopic.php?t=93222

Bonne lecture.

A+


#7

Salut, merci pour l’info, du coup j’ai trouvé le soucis. C’est le logiciel node red qui met tous les GPIO a 0, j’ai paramétré le node GPIO entrée SCL1 sur pullup et ça résolu le problème.


Encore merci pour le lien.


#8

Bonjour,

Effectivement, jamais j’aurais pensé à fouiller du coté de Node Red.
Merci de passer le Topic en [Résolu] en éditant le titre du premier post.

A+