Raspberry Pi 3 & Sublime Text 3


#1

Bonjour,

Nouveau sur le forum et nouveau sur raspberry pi, je cherche à installer Sublime Text 3.
Mon but c’est de faire du développement Python sur cette machine (Rasbian OS). Mon IDE préféré est sublime text (si vous avez des suggestion d’IDE pour python, je suis preneur).

Pour essayer de l’installer j’ai fait un :
sudo apt-get install sublime-text

Mais pas moyende trouver sublime sur la machine. J’ai fait un:
sudo apt-get update

Et j’ai pu observer que cela mettais à jour sublime text.

Est ce que ces commandes suffisent pour l’installer ? Ou est ce que je peux le trouver dans l’arborescence du Raspberry Pi ?

Merci d’avance


#2

Bonjour,

En espérant que les instructions de ce lien fonctionnent

Sinon la méthode officielle est celle-ci

https://www.sublimetext.com/3

A+


#3

Salut @Thomas_Berthemin
et Salut @jelopo

En suivant
https://www.sublimetext.com/docs/3/linux_repositories.html#apt
j’ai une erreur :

pi@raspberrypi:~ $ wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | sudo apt-key add -
OK
pi@raspberrypi:~ $ sudo apt-get install apt-transport-https
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
apt-transport-https is already the newest version (1.4.9).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
pi@raspberrypi:~ $ echo "deb https://download.sublimetext.com/ apt/stable/" | sudo tee /etc/apt/sources.list.d/sublime-text.list
deb https://download.sublimetext.com/ apt/stable/
pi@raspberrypi:~ $ sudo apt-get update && sudo apt-get install sublime-text
Atteint:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Atteint:2 http://archive.raspberrypi.org/debian stretch InRelease
Atteint:3 https://download.sublimetext.com apt/stable/ InRelease
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet sublime-text

Edit : test sur une autre installation de Raspbian stretch laissée par défaut :

pi@raspberrypi:~ $ sudo apt-get update
Réception de:1 http://archive.raspberrypi.org/debian stretch InRelease [25,4 kB]
Réception de:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15,0 kB]
Réception de:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11,7 MB]
Réception de:4 http://archive.raspberrypi.org/debian stretch/main armhf Packages [221 kB]
Réception de:5 http://archive.raspberrypi.org/debian stretch/ui armhf Packages [45,0 kB]
12,0 Mo réceptionnés en 13s (899 ko/s)                                         
Lecture des listes de paquets... Fait
pi@raspberrypi:~ $ sudo apt-get install sublime-text
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet sublime-text

Je ne comprends pas comment tu as débuté une installation :thinking:


#4

Bonjour,

effectivement sublim texte ne fait pas parti des paquet disponible sous Raspbian, et même sur ma Debian il n’est pas dispo. Cette commande de recherche des paquets distribués ne ressort aucun sublim texte.

 $ apt-cache search sublim

Il faut bien l’installer manuellement (si c’est possible) ou trouver un autre éditeur. C’est l’occasion de fouiller un peu sur le net et de comparer ce qui convient le mieux à son usage.

EDIT : @Nabla
Théoriquement après avoir mis à jour /etc/apt/sources.list.d/sublime-text.list et un sudo apt-get update, il devrait apparaitre avec la commande ci-dessus. Toutefois, y a t-il tous les prérequis à une installation complète ?

A+


#5

Hello,

Je m’auto répond, je viens de faire le test, j’ai un petit doute sur le https://download.sublimetext.com/dists/apt/stable/ fourni. A partir d’un navigateur, il ne trouve aucun fichier? Je ne sais pas si ça viens de moi ou du site…

A suivre…

A+


#6

Je confirme ; ça ne change rien dans les sources car ne pointe sur rien !


#7

merci @Nabla pour tes recherches. De ce que j’ai pu trouver dans mes recherches c’est que sublime-text n’est pas dispo sur la distribution linux rasbian. Du coup, j’utilise Geany qui est dessus par défaut.