[Résolu] Désactiver Login/MDP dans retropie ?


#1

Bonjour,

Afin de pouvoir rejouer aux jeux de mon enfance et mon adolescence et les faire découvrir à mes enfants, j’ai acheté un Raspberry Pi3 B+ pour me monter une petite config retrogaming.

J’ai installé la dernière version de Retropie, Recallbox n’étant apparemment pas encore compatible avec le Pi3 B+, et mes premiers essais sont très concluants, à un détail près : au démarrage, je dois entrer un login et un mot de passe.

Certes, j’ai un petit clavier bluetooth (acheté pour une vingtaine d’euros chez Lidl et qui s’acquitte parfaitement de cette tâche) mais mon souhait serait de m’en affranchir totalement et de court-circuiter l’étape du login/mot de passe.

Existe t-il un paramétrage ou une manip à effectuer pour me passer de cette étape ?


#2

Salut,

Tu as batocera qui tourne sur Rpi3b+ me semble-t-il.

Sinon, je n’ai pas testé retropie sur Rpi depuis longtemps (j’en ai installé une version il y a peu sur une machines Linux), donc j’ai un doute.
Je crois que l’image est complète (tu écris Retropie sur la carte et zou, c’est bon).
Tu confirmes que Retropie tourne en direct ou tu as installé Raspbian puis retropie au sein de Raspbian ?

++


#3

Oui, j’ai téléchargé l’image depuis le site de retropie, je l’ai mise sur une micro sd avec disk imager et j’ai demarré le RPi. Raspbian était donc a priori inclus dans l’image.
J’ai ensuite fait les mises à jour via le menu qui va bien.
Après réflexion je ne me souviens pas d’avoir entré de mot de passe lors du premier démarrage.


#4

J’ai fini par trouver !

En cherchant sur le forum de Retropie (en anglais), je suis tombé sur un post qui proposait une méthode en ligne de commande.

Ladite méthode n’a pas fonctionné mais m’a donné de précieux indices sur la marche à suivre.
Du coup, voici une méthode qui marche bien :

Il faut d’abord aller dans le menu de retropie et aller dans “raspi config” puis, dans ce menu, choisir “boot options”.
On a alors un menu dans lequel on choisit “B1 Desktop/CLI” puis dans le nouveau menu “B2 Console Autologin Text console, automaticaly logges as ‘Pi’ user”.

Ensuite, il faut choisir “finish” puis “yes” quand il demande si on veut rebooter… et le tour est joué !

Plus besoin d’allumer le clavier bluetooth, ça démarre sans qu’on ait à entrer de login ni de mot de passe.

En tout cas merci pour ton aide.


#5

Salut,

Et merci à toi pour ton retour qui pourra être utile à la communauté !

En fait tu avais bien installé l’image “automatique” de Retropie.
Il est vrai que comme Retropie est basé sur Raspbian, il “suffisait” d’exécuter “raspi-config”.
Finalement, ça coulait de source.
Mais, comme on dit “ça va sans dire … mais ça va mieux en le disant !”

Bon jeux :wink:


#6

Merci.

Effectivement, j’ai mis l’image “automatique”.

J’ai vu au premier démarrage que ça tournait sur Raspbian (ce qui m’a semblé logique, il faut bien un système à un moment où à un autre) mais je ne m’étais pas vraiment posé la question et comme je suis novice sous Raspbian, ce n’était pas évident pour moi au départ.

Prochaine étape maintenant que j’ai goûté au RPI : monter une config, toujours avec un RPi, pour faire tourner des applis de bureautique (en gros un traitement de texte et un tableur, genre suite libre office).

J’ai vu qu’il y avait ici un tuto qui va bien pour monter ce genre de config : https://raspbian-france.fr/ordinateur-bureau-linux-raspberry-pi/

En attendant, j’ai retrouvé le plaisir de jouer à Worms et à Lost Vikings et ça c’est chouette :slight_smile:


#7

BONJOUR COMMENT FAIRE POUR OUVRIR LE MENU CONFIG JAI LE MEME PROBLÈME QUE TOI JAI ACTIVE NY WIFI NY SSH TU PEUT MAIDE JE SUIS COINCE


#8

CA MARCHE PAS CA CORROMPU LIMAGE IMPOSSIBLE DE CONNECTE POURQUOI APRES LA MISE AJOUR IL DEMANDE UN MOTS PASSE JAI DESACTIVE COMME TA CA MARCHE PAS IMPOSSIBLE CE CONECTE


#9

Merci @MisterTi, j’avais pourtant souvenir des log de connexion mais ton liens ma bien aider. Surtout pour la désactivation de la demande de MdP au démarrage, merci pour le partage.

@nabil_nabil évite les majuscules ça donne l’impression que tu crie et ça donne pas envie de te répondre ^^