[Résolu] Echec installation, Whouaï ?


#1

Bonjour
ce matin j’ai offert une nouvelle micro SD (32Gb) à mon Raspberry 2 pour en faire un media center.
J’ai scrupuleusement suivi le modop en page d’accueil (OMSC).

Eh bien rien de rien sur l’écran de ma TV.
Maintenant je fais koi ?? (j’ai évidement réessayé en formatant la SD Carte avec SDFormatter) en vain.

détails: dernière version 2018.07 installée, avec wifi auto.
Merci pour vos éclairages :tired_face:

(avec mon autre carte il fonctionne très bien: jessie / clavier Florence / epyphany / wifi …)
Philippe


#2

Hello,

Je te conseille d’écrire l’image avec etcher pour éviter les erreurs.
Mais je te conseille aussi de tester ta carte SD en y écrivant l’image (avec etcher) de Etcher afin d’être sûr que ça puisse tourner (carte incompatible ?)

Redis nous,


#3

Bonjour Nabla
merci pour le tuyau.
J’utilise une carte Scandisk Ultra microSDHC UHS1
Je vais essayer Etcher
et je vous tiens au courant
:slight_smile:


#4

Suite…
toujours rien:tired_face:

j’ai donc installé Etcher, téléchargé l’image directement depuis OSMC https://osmc.tv/download/
–> OSMC_TGT_rbp2_20180805.img.gz
reformatté la SD carte avec SDformatter, flashé l’image avec Etcher : -> résultat négatif

j’ai refait la même manip avec une ancienne SDcard de 8Go. Même résultat.

j’ai déconnecté le dongle wifi, le clavier en bluetooth et la souris par USB. RP2 nu --> pas mieux, la TV détecte un device sur HDMI2 mais seulement une mire colorée, pas comme d’habitude avec ma SD card Jessie
A chaque fois Etcher teste son flashage et ca semble bon. Comment vérifier cette card en dehors du RP2 ?

je suis sec.
pour info la carte SD une fois flashée n’est plus reconnue par le PC (perso ca me semble normal)

des idées ???


#5

Yo,

Pour info, pas besoin de formater ; etcher gère le tout.
Tu lances Etcher, tu lui dis quoi écrire et il formate + écrit l’image d’un seul coup (puis vérifie l’image écrite).

On peut tester un truc.
Tu télécharges Ubuntu et tu écris l’image sur ta carte avec Etcher puis tu démarres ton PC en “bootant” sur la carte SD pour voir si tu PC démarre sur Ubuntu

Sinon, tu télécharges et essayes Stretch car ma phrase :
Mais je te conseille aussi de tester ta carte SD en y écrivant l’image (avec etcher) de Etcher afin d’être sûr que ça puisse tourner (carte incompatible ?)
est complètement idiote :slight_smile: (le boulet ; désolé)
Je voulais dire :
Mais je te conseille aussi de tester ta carte SD en y écrivant l’image (avec etcher) de Stretch afin d’être sûr que ça puisse tourner (carte incompatible ?)

Bref,
Tu testes Raspbian Stretch sur ton Rpi23 et/ou Ubuntu sur ton PC au moyen de cette carte SD de 32 Go

(j’ai la même carte en 16 Go = parfait)

++


#6

Hello
J’ai finalement installé Stretch avec succès (https://www.raspberrypi.org/downloads/) puis Etcher pour flasher le ZIP.
Bon, quand même il voulait me faire formatter un disque F: qui “venait” avec le E: sur la SD card. J’ai refusé of course.:roll_eyes:

Ensuite la SD Card glissée dans le RP2, tout s’est magiquement installé tout seul (clavier et souris reconnues), wifi pas ok quand j’ai rentré le psw mais oui tout seul après reboot. Bcp de progrès de confort sur cette distri. Quand j’ai installé Jessie en 2015 il fallait tout monter morceau par morceau à la ligne de cmd… :rofl:
Conclusion : la carte n’est pas en cause.

Any ideas ? :thinking:
(je me dis que puisque Stretch est maintenant installé, je vais peut-être acheter une carte 16Gb classe 10 pour OSMC, … mais bon cela reste un mystère …)
Ca va attendre demain soir maintenant


#7

Re,
La soirée ne faisant que débuter, on colle OSMC sur cette carte de 32 Go avec Etcher et on voit :slight_smile:

Tu veux dire que ta carte contient 2 partitions ?

Je viens de “flasher” une clef USB de Stretch avec la nouvelle version, toute la clef a été utilisée avec effacement des partitions /boot et /rootfs.

++


#8

Hello
Back from the boulot. :wink:
Je viens de reformatter ma SDcarte 8Gb avec SDformatter (erase, + system), --> vierge presque 8gb (FT32)
Un coup d’ Etcher sur l’image de OSMC --> flashing ok.
Carte ne devient plus lisible par W10. Ca me semble logique.

Je la glisse dans le RP2 à l’insu de son plein gré. :grinning:
–> belle mire sur la TV, rien ne se passe.:sob:

je vais insister avec OSMC
A suivre


#9

STOP STOP
je viens de regarder si j’avais bien le bon RP. en fait ce n’est pas un RP2 mais un RP1 B+1 de jan 2015.:flushed:
donc je vais copier la bonne image
et je reviens raconter si ca fonctionne
Sorry , sorry , sorry


#10

:smile:

Et tu peux laisser tomber SDformatter ; Etcher est un grand qui sait faire :wink:


#11

Donc …
c’était bien ça… mauvais choix d’image de ma part.
Ce bébé fonctionne bien
je m’en vais visionner quelques essais.
Bonne soirée et merci pour les coups de main


#12

Cool,
Merci pour le retour.
Tu peux éditer ton message initial et ajouter [Résolu] au début du titre ?
++


#13

Voilà c’est fait.:rofl:

Me reste à réussir à lire un HD externe.
pour l’instant j’ai essayé avec un disque sans alimentation. Il ne le voit pas.
Pas plus avec une simple clé USB .
Je viens de regarder, ma petite SD Card avec OSMC, semble avoir deux partitions quand je la lis sur mon PC W10 , E: en FAT32 (240M pour le système), F: que je ne sais pas lire.
J’imagine que c’est logique. Je vais gratter.:thinking:

Bon w-end ensoleillé :sunglasses:


#14

Hello,

Normalement, il doit pouvoir voir un périphérique USB.
Tu pourras créer un autre sujet si besoin :wink:
Je n’ai pas de Windows chez moi donc je ne pourrai pas te dire, mais ça parait logique d’avoir une partition /boot et une autre (lisibles avec un PC Linux normalement).

++


#15

Update.
J’ai branché un vieux HD externe alimenté (un vrai poids lourd). Il est bien reconnu. :grinning: Youpi !
Ca venait de cela
pour l’instant il indexe un répertoire de photos et semble bloqué. pas d’urgence.
Ca se présente bien. pas à pas. C’est prometteur.


#16

Update
Ca y est , le HD est indexé. J’ai pu visionner quelques films et photos, c’est parfait, audio très claire, belle image.

GENIAL, GENIAL, GENIAL
ce petit RPI , qui est plein de ressources va retrouver une nouvelle vie !!
:sunglasses::sunglasses::heart_eyes::heart_eyes::star_struck::star_struck::sparkler::sparkles::heartpulse:


#17

Et voilà un nouveau membre heureux :wink:
Pour info, j’ai un Rpi Zéro qui décode un film H264 en 1080p
(bon le 1080p en h265 ne passe pas mais c’ets logique)

Bon amusement :slight_smile:


#18

Yep
Prochains challenges:
1:- Lire des films depuis mon Google Drive
2:- piloter OSMC depuis mon smartphone avec Yatse

A suivre