[Résolu] Lancer une application au démarrage... et la fermer


#1

Bonjour!
Je suis en train de faire mon premier projet à base de Raspberry, mais j’aurais besoin de votre aide…
Je vous explique :

Après bien des difficultés avec systemd, j’ai enfin réussi à lancer une application (lin_guider - https://sourceforge.net/projects/linguider/) au démarrage de ma Raspberry (sous Raspbian) grâce a un petit script bash et au fichier .bashrc. Je précise que la Raspberry s’allume en mode console autologin. Voici les fichiers dem.sh et .bashrc en question :

#!/bin/bash
startx /home/pi/lin_guider/lin_guider_pack/lin_guider/lin_guider

# starts LIN_GUIDER (if not started yet)
ps -a | grep -v grep | grep dem.sh > /dev/null
result=$?
if [ “${result}” -eq “0” ]
then echo “LIN_GUIDER is already running!”
else
tty | grep tty1 > /dev/null
result=$?
if [ “${result}” -eq “0” ]
then
echo “LIN_GUIDER starting…”
sudo /home/pi/my_app/dem.sh &
else
echo “LIN_GUIDER not started (autostart reserved to tty1)”
fi
fi

(désolé pour le code, je n’ai pas trouvé comment remmettre correctement les indentations :confused: ; voici celui qui m’a servi d’exemple, en bas de page : https://wiki.mchobby.be/index.php?title=Rasp-AutoStart-Script )

Cependant, j’ai deux problèmes.
Le premier est que lorsque j’ouvre un menu (une fenêtre) dans mon application, il m’est impossible de la fermer ! En effet, la barre qui contient les icônes “agrandir”, “diminuer”, “fermer” au dessus des fenêtres n’est plus disponible. L’affichage est aussi différent de l’affichage “normal” (quand je lance l’application manuellement).

Le deuxième est que j’avais configuré ma raspberry en tant que hotspot pour pouvoir me connecter via vnc à la Pi depuis mon telephone ou mon pc, mais je ne trouve plus ce réseau lorsque mon application est lancée. Il semble que le processus de lancement bloque la création de ce wifi et je ne sais pas pourquoi.

Voilà, j’espère que je suis assez clair, sinon, dites-le moi :slight_smile:
Au plaisir de vous lire,

Arnaud


#2

Salut,

Je ne comprends pas car tu démarres en mode console mais tu lances le bureau graphique (avec startx).
Pourquoi ne pas démarrer en mode graphique et lancer l’application simplement avec autostart ?
(avec sudo nano /etc/xdg/lxsession/LXDE-pi/autostart)


#3

Ah… je n’avais pas pensé à cette option là !
Je vais aller chercher dans cette direction alors, merci du conseil !


#4
  1. Lancement automatique d’un script lors du démarrage de l’interface graphique
  2. Lancement automatique d’un script lors du démarrage “initial” du Raspberry

#5

Ben voilà, un souci qui aura perduré pendant quelques semaines à été résolu en littéralement 3 min !!

Merci pour ces réponses ultra-rapides et super utiles ! :slight_smile:
Au passage, super site, il passe directement dans mes favoris !


#6

[Mode sage et Poète]
Parfois à vouloir suivre absolument la première route choisie, on s’égare alors que le sentier d’à côté était nettement plus rapide :wink:
[/Mode sage et Poète]

Tu peux éditer ton premier message afin d’insérer [Résolu] dans le titre (sauf si le reste reste en questionnement/recherche de solution) ?

@+


#7

Excellent, je retiens :slight_smile:
Ok, je fais ça


Lancement d'un programme python au démarrage