[RESOLU] Rasperry3 + picamera2 = failed


#1

Bonjour,

J’essaye de faire fonctionner ma caméra V2.1 sur ma raspberry 3 (avec raspbian-jessie-lite )

pi@raspberrypi:/ $ raspistill -v -o test.jpg

raspistill Camera App v1.3.8

Width 3280, Height 2464, quality 85, filename test.jpg
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode ‘auto’, AWB Mode ‘auto’, Image Effect ‘none’
Metering Mode ‘average’, Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn’t be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Ca ne fonctionne pas !
J’ai déjà mis mon système à jour :

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo rpi-update

Tout est à jour sans aucune erreur.
La camera est bien activée dans raspi-config

Petite chose qui me semble étrange c’est que la camera n’apparait pas dans le dossier device.

pi@raspberrypi:/dev $ ls
autofs           loop0               ptmx    serial1  tty21  tty40  tty6       vcs4
block            loop1               pts     shm      tty22  tty41  tty60      vcs5
btrfs-control    loop2               ram0    snd      tty23  tty42  tty61      vcs6
bus              loop3               ram1    stderr   tty24  tty43  tty62      vcsa
cachefiles       loop4               ram10   stdin    tty25  tty44  tty63      vcsa1
char             loop5               ram11   stdout   tty26  tty45  tty7       vcsa2
console          loop6               ram12   tty      tty27  tty46  tty8       vcsa3
cpu_dma_latency  loop7               ram13   tty0     tty28  tty47  tty9       vcsa4
cuse             loop-control        ram14   tty1     tty29  tty48  ttyAMA0    vcsa5
disk             mapper              ram15   tty10    tty3   tty49  ttyprintk  vcsa6
dri              mem                 ram2    tty11    tty30  tty5   uhid       vcsm
fb0              memory_bandwidth    ram3    tty12    tty31  tty50  uinput     vhci
fd               mmcblk0             ram4    tty13    tty32  tty51  urandom    watchdog
full             mmcblk0p1           ram5    tty14    tty33  tty52  vc-cma     watchdog0
fuse             mmcblk0p2           ram6    tty15    tty34  tty53  vchiq      xconsole
gpiomem          mqueue              ram7    tty16    tty35  tty54  vcio       zero
hwrng            net                 ram8    tty17    tty36  tty55  vc-mem
initctl          network_latency     ram9    tty18    tty37  tty56  vcs
input            network_throughput  random  tty19    tty38  tty57  vcs1
kmsg             null                raw     tty2     tty39  tty58  vcs2
log              ppp                 rfkill  tty20    tty4   tty59  vcs3

La mémoire du GPU:

pi@raspberrypi:/dev $ vcgencmd get_mem gpu
gpu=256M

J’ai déjà fait plusieurs manipulations trouvées sur le net.
Je n’ai plus d’idée pour chercher le problème !
Comment puis être sur que la camera n’est pas défaillante? ( Elle est neuve et j’en ai pris soin )
Comment puis la voir sur le système? Exit-il une commande du type ls-camera ?

En vous remerciant!


#2

Sakut @polochio :blush:

Je sais que j’ai eu un problème similaire y’a déjà un petit bout de temps… et le problème venait juste du branchement de la caméra sur la Raspberry-Pi 2… J’ai simplement clippé à nouveau la caméra & elle fonctionnait à merveille !!! Mais si le problème ne vient pas de là je ne peux t’aider :confused: !!!

J’espère t’avoir aider :wink:

Electroniquement

Titouan


#3

Salut,

Idem ; pour moi = tu commences par vérifier que la caméra est bien branchée dans le bon sens et le “clip” bien remis.

Voici comment j’ai connecté la camera (qui tourne sans problème) : côté sans écriture vers la prise RJ45 ; côté avec écritures vers carte micro-SD.
Une petite photo compressée :

Après, elle a peut-être un défaut d’origine. Mais ça serait “pas de bol”.

@+


#4

Bonjour,

Merci pour votre aide,
Je pense que ma camera est bien branché

Si je tourne la nappe, ou que je déconnecte la camera, j’ai un autre message.

pi@raspberrypi:~ $ raspistill -o test.jpg
mmal: Cannot read cameara info, keeping the defaults for OV5647
mmal: mmal_vc_component_create: failed to create component ‘vc.ril.camera’ (1:ENOMEM)
mmal: mmal_component_create_core: could not create component ‘vc.ril.camera’ (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly

Avez-vous d’autre idée?


#5

Salut @polochio :grin:

Je n’ai jamais eu ces messages d’erreurs mais en fouinant sur le net anglais j’ai trouvé des forums qui parlent de ce types de ‘pannes’ ! Va jeter un coup d’œil aussi :wink: je pense que cela peut t’aider :yum:

https://www.raspberrypi.org/forums/viewtopic.php?t=60518&p=453532

Bonne chance :relieved:


#6

Merci,
Je suis déjà tombé sur ces sites…
Mais les mises à jour ne changent rien.


#7

Hello !

Petite question, tu utilises motion (ou un autre soft de vidéo en continue?) si oui, tu dois le stopper avant de lancer raspistill.

Ensuite 2ème question, tu as du 1-wire (Sonde de température typiquement?


#8

Je n’ai pas réussi a faire fonctionner motion (sûrement le même problème)
J’ai cru comprendre que raspistill est plus simple, fiable… donc j’essaie avec.

Concernant le 1-wire, je n’ai rien. Il y a un rapport avec la camera?
Actuellement il est activé. Désactivé, j’ai le même message!


#9

tu peux tapper ceci :

sudo service motion stop

et re-tenter avec raspistill


#10

J’avais oublié que j’ai désinstallé motion.

pi@raspberrypi:~ $ sudo service motion stop
Failed to stop motion.service: Unit motion.service not loaded.

La camera peut-elle fonctionner sans motion?
Le problème est toujours là.


#11

Je préferais être sur que Motion n’étais pas lancé :slight_smile:

Tu as d’autres softs pour utiliser ta caméra?

Sinon je n’ai pas d’autres idées


#12

Salut,

J’avoue que je rejoins totalement Gpapig.

Si tu n’as rien sur ta carte SD, je serais même partisan de refaire juste une install’ de Raspbian.

Installation de la dernière image de Jessie.
Puis activation Cam et SSH, modif du mot de passe, etc.
Puis MAJ totale avec sudo apt-get update -y && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y && sudo reboot
Puis tu lances juste raspistill -o test.jpg

Et tu reviens nous dire que tout va bien (ou pas …)

++


#13

Bonjour,

Concernant la re-install de rasbian, j’ai déjà fait la manip.

J’ai trouvé le problème. :slight_smile:
J’ai demandé a un ami de me prêter sa camera pi et miracle ça fonctionne (du premier coup! )

Je vais renvoyer ma camera au SAV, et d’ici 1 semaine je pourrai enfin commencer à jouer avec ma camera!

Merci a tous.
Et joyeux noël!


#15

Bonjour,

Je me permets d’ajouter ma trouvaille si ça peut aider d’autres personnes.

Sur mon Pi Zero W, impossible de passer en résolution supérieure à 640x480. Je voulais du 1024x768.

J’ai réussi en changeant le GPU_MEM qui était à 128 en 256

dans /boot/config.txt => gpu_mem=256


#16

merci d’avoir poster sa pourra être utile a d’autre :thumbsup:
car je vois pas bien le raport , mais des fois il y a des truc qu’on comprends pas , en plus je suis pas un expert a se qui touche a la vidéo .

Le gpu_mem si j’ai bien compris , sert à définir la mémoire partagé entre le cpu et GPU,
la valeur est en mégo octect et est octroyé au gpu

donc la tu force le gpu a prendre 256 Mo

sur les pi la valeur restant est prise par le cpu , donc tecniquement il reste 256 mo donc tu a partagé la mémoire en 2 ,

le pi zero W a 512 Mo contre 1go sur pi 3 et pi 2

l’explication de la valeur du gpu_mem je l’ai trouver ici gpu_mem http://elinux.org/RPiconfig

ma théorie est donc , (pas sur qu’elle soit exact ) si la valeur mémoire est trop faible sur le GPU il ne peux accéder a de grande résolution et c’est lui qui bosse dans ce cas

donc on retrouve sa aussi sur les PC classique quand aloue de la mémoire sur une carte graphique
et surtout sur les PC portable sui dispose d’une carte mere intégré celui si galére dans les grande résolution si le GPU est trop solicité .

Je ne savais pas que la solution a un résolution faible pouvait etre régler comme sa sur PI

bravo @cook32 pour cette trouvaille car c’est documenter nul part ou en tous cas j’ai pas trouvé


[résolu] Lecture fichier mkv RPI3 USB
#17

En fait je suis parti de ce post : http://raspberrypi.stackexchange.com/questions/13764/what-causes-enospc-error-when-using-the-raspberry-pi-camera-module

Le gars dit “As of may 2016, the GPIO_MEM=128 is no longer enough. Increasing it from 128 to 144 made the error go away.”

et en fait je pense qu’il s’est trompé avec le paramètre GPU_MEM vu qu’au dessus il avait indiqué
“Error : ENOSPC displayed. Camera is probably running out of GPU memory. Check config.txt in the /boot/ folder. The gpu_mem option should be at least 128.”

D’où mon changement qui d’ailleurs s’est avéré payant aussi sur mon ancien PI 3 sur lequel j’ai mis à jour motion en me basant sur cet article pour Jessie :

http://forums.framboise314.fr/viewtopic.php?t=2333

Bonne journée !