Transmission port fermé avec openvpn


#1

Bonjour tous,
j’ai suivi le tuto https://raspbian-france.fr/connectez-raspberry-pi-vpn/
Quand j’active openvpn, le port par défaut de transmission (51413) est fermé ; et il est bien ouvert quand je ne lance pas openvpn.
Je ne sais toujours pas pourquoi, j’ai beaucoup cherché sur le net. Je croyais faire simple, sans pare-feu, de pfsense ou autre firewall. J’ai bien ouvert et redirigé le port 51413 sur ma box. J’ai même essayé avec un autre port (le 55000). Openvpn a l’air de me fermer le port d’écoute de transmission. Du coup j’ai pas d’upload pour mes téléchargements.
J’ai essayé plusieurs solutions aussi en rajoutant les ports avec iptables ; mais apparemment l’install devrait être simple, je comprends pas pourquoi il faudrait rajouter des iptables, si on a pas besoin de pare-feu…

Ma config : un raspberry model 3, une SFRBOX (récente, la dernière je crois) ; raspbian stretch ; openvpn dernière version, transmission dernière version (tout a été mis à jour). J’ai aussi Ipvanish comme dans le tuto pour le VPN ; et enfin no-ip en dyndns pour avoir un nom accessible de mon rapsberry depuis l’extérieur avec mon ip changeante.

Je creuserai encore avec des posts de ce forum, mais je fatigue, j’ai passé le week-end dessus ; ce soir si j’ai pas de solutions je retente en réinstallant carrément tout le bouzin : la raspbian, l’openvpn, l’ipvanish, le transmission…
Si d’ici là y a des pistes à explorer… Je penche pour un problème de openvpn, mais j’ai pas vu les logs…
Merci.


#2

Bonjour,

Difficile de répondre sans infos techniques ni logs. D’autant plus que je ne connais pas du tout openvpn.

Par contre à tout hasard, avec vous configuré transmission pour qu’il fonctionne sous openVPN ?

Voir ce tuto
9) Configurer transmission-daemon pour qu’il utilise le tunnel VPN :

A+


#3

Merci pour les infos jelopo.
LEs logs sont pas nombreux malheureusement pour transmission ni OpenVPN.
Pour l’instant je suis un peu dégouté, j’ai passé trop de temps à faire, essayer, refaire, suivre un tuto, 2 tutos, 3 tutos…
Le problème c’est les configurations différentes… Je trouve que c’est un peu l’enterrement de Linux. Il y a trop de distrib différentes avec des evrsions diff"rentes à l’intérieur des distribs, et des fois ça change énormément. Si Linux était tellement stable et fiable, pourquoi l’avoir changé, transformé, fait évoluer pour que ça devienne un amas de briques qui s’entassent… jusqu’à que ça se casse la gueule.
Désolé, je suis un ptit peu amer, je suis dans l’informatique, technicien depuis une dizaine d’années, et en fait je crois que j’en ai marre de l’informatique. Je sais bien que la nouveauté et le changement et l’évolution font partie du boulot… mais au bout d’un moment, … on perd les gens… Je voulais aller vers Linux pour aussi le démocratiser, que de plus en plus de gens l’utilisent, je vois que c’est pas la priorité des développeurs, et que l’uniformisation, l’homogénéité ne sont plus de mises. C’est à chacun de faire son truc dans sa distrib, avec sa version, qui marchera avec sa version et sa distrib, et pi avec les autres on verra bien…
La petite Raspbian promettait, elle devient trop ardue pour moi. J’arrive pas à monter un VPN. ça devient trop compliqué, ça plante ou ça marche pas… Trop de choses à faire avec un VPN, un dyndns, transmission, un disque dur NTFS… pfff ça devient… trop galère… Je jette l’éponge, je vais voir un psy et je reviens quand je serai plus motivé… hasta luego…


#4

Salut

je me réponds à moi-même, j’aime bien…
J’ai trouvé une solution, pas à tous mes problèmes, mais bon…
J’ai monté le disque en ntfs mais avec ntfs-3g (sinon ça marche pas pour moi). Il faut faire aussi des liens symboliques entre les différents fichiers de settings.json pour transmission. Sinon on s’y retrouve pas, il faut alors pointer sur un fichier qu’on peut facilement éditer, et le mieux c’est dans un /home/pi/.config/transmission-daemon/settings.json
Ensuite si on veut pas avoir de galère comme j’ai eu avec des permissions refusées, il faut que l’utilisateur de transmission soit pi, c’est mieux, sinon par défaut c’est debian-transmission et là c’est galère (encore, que de galères). Et le top qui marche pour moi encore c’est ici que je l’ai trouvé :


c’est qu’il faut mettre pi en utilisateur et surtout aussi en tant que “lanceur” du service. Sinon ça marchait pas pour moi. Voir le post donc de Sammaye avec systemctl et le service de transmission. Et la commande qui va bien :slight_smile:
sudo nano /etc/systemd/system/multi-user.target.wants/transmission-daemon.service
Je préfère nano à vi.

C’est pas fini :slightly_smiling_face:
ensuite, j’avais des problèmes avec openvpn, ipvanish, et transmission. J’en ai toujours (des problèmes, qui n’en a pas…), mais à vérifier demain, je crois que le port 51413 (port par défaut de transmission) est encore fermé en sortie, voir dans les “Préférences” de transmission, onglet “NEtwork” => port 51413 is closed.
Ce qui fait que je peux télécharger mais pas seeder en retour. J’ai bien ouvert le port 51413 dans les 2 sens sur ma box (SFR Box la dernière, version NB6V2). J’ai rajouté aussi le port 1194, mais je me souviens plus où j’ai trouvé cette info et du coup je sais plus si c’est pour transmission ou pour noip… :frowning: Dans le doute je l’ai laissé ouvert sur ma box.
Là pour l’instant, je suis content :wink:
même si je lance openvpn en tâche de fond (il se lance pas au démarrage), j’avais suivi des tutos pour le lancer au démarrage ça m’avait planté ; donc je préfère le lancer “à la main” et de toutes façons le raspberry tourne tout le temps, et si il plante ben je relancerais le openvpn.
Et enfin content même si pour l’instant j’ai pas l’impression que transmission upload via mon openvpn et mon noip. Il faudra que ça marche parce que mon site de peer2peer exige un ratio, il faut donc seeder, normal :wink:

Voilà, merci et je vous tiens au jus si jamais ça peut intéresser pour la suite
et sinon à bientôt pour de nouvelles aventures…


#5

Salut l’ami

le port 1194 c’est pour openvpn car c’est le port défaut , si tu a qu’une instance et que tu à pas changer , normalement openvpn se lance au démarrage sur le serveur si le fichier de conf et placer dans /etc/openvpn enfin c’est le cas sur les distribe que j’utilise ,donc sur raspbian je c’est pas comment sa marche mais sa doit être pareil .

pareillement mais j’sui linuxien de basse pour ma part et jconnais pas mal openvpn donc si tu a besoin d’aide hésite pas , par contre transmission c’est pas ma came


#6

Salut camarade,
merci pour la réponse.
Alors je patine toujours…
Ce dont je suis sûr c’est que c’est openvpn qui me ferme le port 51413 de transmission. La preuve : avec openvpn et une ip publique donné par ipvanish, sur transmission le port 51413 is closed. Sans openvpn, avec mon ip publique de ma box sfr, le port 514132 is open !
Donc à creuser là-dedans…