Dépendances installation owncloud


#1

Bonjour,

j’ai un peu de mal avec l’installation d’owncloud. Je n’arrive pas trouver une solution
à mes problèmes de dépendances :

aptitude install owncloud donne :

owncloud : Dépend: libjs-jquery-minicolors (< 2~) but 2.2.6+dfsg-3 is installed
Dépend: php-doctrine-dbal (< 2.5) but 2.9.2-1 is to be installed
Dépend: php-pimple (< 2) but it is not going to be installed
Dépend: php5 (>= 5.3.8) which is a virtual package and is not provided by any available package

        Dépend: php5-cli which is a virtual package and is not provided by any available package

        Dépend: php5-gd which is a virtual package and is not provided by any available package

        Dépend: php5-json which is a virtual package and is not provided by any available package

        Dépend: php5-mysql which is a virtual package and is not provided by any available package

ou
php5-pgsql which is a virtual package and is not provided by any available package
ou
php5-sqlite which is a virtual package and is not provided by any available package

Une idée ?

Frédéric


#2

Salut,

ça améliore un truc de faire ça ?
sudo apt-get install apache2 mariadb-server libapache2-mod-php5
sudo apt-get install php5-gd php5-json php5-mysql php5-curl
sudo apt-get install php5-intl php5-mcrypt php5-imagick

Sinon, pas mieux de passer à php7 ?


#3

Ben non, ça coince toujours.

sudo apt-get install apache2 mariadb-server libapache2-mod-php5
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Aucune version du paquet libapache2-mod-php5 n’est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu’il est devenu obsolète
ou qu’il n’est disponible que sur une autre source

E: Le paquet « libapache2-mod-php5 » n’a pas de version susceptible d’être installée

Pour passer à php7, quels sont les paquets à installer ?


#4

Re,

Non testé.

Perso, j’avais utilisé NextCloud plutôt que OwnCloud et en passant par YunoHost ce qui est TRES facile :wink:


#5

Bonjour,
moi aussi j’ai commencé avec owncloud mais j’ai eu pas mal de problèmes, surtout de mises à jour, car apparemment à un certain moment, l’équipe s’est plus ou moins délitée.
Depuis que je suis passé sur nextcloud, en utilisant la distrib toute prête “nextcloudPI” je n’ai plus de problèmes de mises à jour, sauf avec certains modules un peu exotiques (Gpxedit, Gpxpod et gpxmotion) qui étaient mises à jour avec un peu de retard.


#6

Bonjour,

Je confirme ! Nextcloud sur Younohost marche nicquel depuis presque 1 ans!